[rrd-developers] ld: Can't find library for -lSM

Peter Brink peter.brink at sveaekonomi.se
Mon Apr 16 11:31:28 CEST 2012


I hope I post this question on the right list.

I'm trying to compile rrdtool 1.4.7 on a HPUX 11.31 itanium server. My objective is to get a new Munin site up and running. 

I'm using perl 5.10.1. The built-in perl on HPUX 11.31 is 5.8.8. Compiling against that Perl version was successful but when I tried to start Munin DynaLoader.pm complained that it couldn't load RRDs.pm. So now I'm trying to compile for use with an existing perl 5.10.1 installation.

The configuration script was set up as: ./configure --prefix=/usr/local --disable-python

That part went fine, and I goth this message:

Config is DONE!

          With MMAP IO: yes
      Build rrd_getopt: yes
       Build rrd_graph: yes
       Static programs: no
          Perl Modules: perl_piped perl_shared
           Perl Binary: /usr/local/bin/perl
          Perl Version: 5.10.1
          Perl Options: PREFIX=/usr/local LIB=/usr/local/lib/perl/5.10.1
          Ruby Modules:
           Ruby Binary: no
          Ruby Options: sitedir=/usr/local/lib/ruby
    Build Lua Bindings: no
    Build Tcl Bindings: no
 Build Python Bindings: no
          Build rrdcgi: yes
       Build librrd MT: yes
           Use gettext: no
           With libDBI: no
          With libwrap: yes

             Libraries: -lglib-2.0 -lcairo -lcairo -lcairo -lm  -lwrap -lcairo -lpng15   -lpangocairo-1.0 -lcairo -lpangoft2-1.0 -lpango-1.0 -lm -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl   -lxml2

But when I run gmake I get:

# gmake
gmake  all-recursive
gmake[1]: Entering directory `/usr/local/src/rrdtool-1.4.7'
Making all in po
gmake[2]: Entering directory `/usr/local/src/rrdtool-1.4.7/po'
gmake[2]: Leaving directory `/usr/local/src/rrdtool-1.4.7/po'
Making all in src
gmake[2]: Entering directory `/usr/local/src/rrdtool-1.4.7/src'
  GEN    librrd.sym
  CCLD   librrd.la
ld: Can't find library for -lSM
Fatal error.
collect2: ld returned 1 exit status
gmake[2]: *** [librrd.la] Error 1
gmake[2]: Leaving directory `/usr/local/src/rrdtool-1.4.7/src'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/local/src/rrdtool-1.4.7'
gmake: *** [all] Error 2

The relevant parts of my environments:

I've tried to figure out what library rrdtool is complaining but about I haven't been able to find any info her or anywhere else on the net.
It's probably something quite trivial but it got me stumped.

Thanks in advance for any pointers.

Peter Brink 
Svea Ekonomi 
Växel: +46 8 735 90 00 
Adress: Solnavägen 102 A 
Box 100, 169 81 Solna 
peter.brink at sveaekonomi.se 

More information about the rrd-developers mailing list