[rrd-users] Re: Fetching data from RRA's

W. James Showalter, Jr. gamma at mintaka.iern.disa.mil
Mon Aug 16 20:26:15 MEST 1999

That worked!!  It appears that I need to specify the time period.  As
Tobi said in an earlier message it keys on time first, resolution
second.  Since I was never specifying time and there was only one 24 hour
period, it used the 24 hour period (default) instead and ignored the
resolution. I guess the resolution is used to break ties when the time
periods for RRA's are the same and ignored otherwise - just a hunch


On Mon, 16 Aug 1999, Alex van den Bogaerdt wrote:

> >  
> > Now, I assume that if I want to fetch the contents of the second RRA, I type:
> > 
> > rrdtool fetch test.rrd AVERAGE -r 7200
> > 
> > Since every data point is based on 7200 seconds (2 hours) worth of data.
> > However, I keep getting the data for the 24 hour RRA. Am I
> > misunderstanding something?  I did a dump and the data is definitely
> > there.
> >   
> Seems fine to me. Either I'm having the same problem in parsing the docs,
> or you've found an undocumented feature.
> Have you tried to fetch more than one day of data (--start end-2d) ?
> Regards,
> Alex

* To unsubscribe from the rrd-users mailing list, send a message with the
  subject: unsubscribe to rrd-users-request at list.ee.ethz.ch

More information about the rrd-users mailing list