[rrd-users] Re: problem with compiling rrdtool 1.0.17

Trang Tran ttran at Asera.com
Mon Apr 24 23:02:48 MEST 2000

Thank you Dave.
Since it was complaining about ../src/.libs/librrd_private.a, i just made a
link to ../src/.libs/librrd_private.la.  I have no idea what that does, but
when i ran "make site-perl-install" again, it didn't complain.  I also went
into the mrtg.cfg and enable UserRRDTool to yes, and once again...no errors.
Now all i have to do is learn how to use rrdtool....
Thanks again!!


-----Original Message-----
From: Dave Plonka [mailto:plonka at doit.wisc.edu]
Sent: Monday, April 24, 2000 12:44 PM
To: rrd-users at list.ee.ethz.ch
Cc: Trang Tran
Subject: Re: [rrd-users] problem with compiling rrdtool 1.0.17

On Mon, Apr 24, 2000 at 12:04:15PM -0700, Trang Tran wrote:
> I was able to run  "sh configure --enable-shared" without error messages,
> but when i ran "make", i've got these error messages.  I've even tried
> site-perl-install" and the result is still the same
> make[2]: *** No rule to make target `../src/.libs/librrd_private.a',
> by `RRDs.c'.  Stop.
> Any help is greatly appreciated.  Thanks!

I just had the same problem under Solaris 2.6, gcc-2.95.2,
binutils-2.9.1, make-3.79:

   $ ./config.guess
   $ ./configure --prefix=/opt/local --enable-shared
   $ make
   Making all in tcl
   make[1]: Entering directory `/opt/local/source/rrdtool-1.0.17/tcl'
   gcc -g -O2 -Wall -pedantic -Wshadow -Wpointer-arith -Wcast-align
   types -Wmissing-declarations -Wnested-externs -Winline  -fPIC -fPIC
   /include -I../src  -I../gd1.3 -c tclrrd.c -DVERSION=\"1.0.17\"
   tclrrd.c:357: warning: no previous prototype for `Tclrrd_Init'
   /usr/ccs/bin/ld -G -z text -L/opt/local/lib -L../src  -L../src/.libs
tclrrd.o -o
    tclrrd.so -lrrd_private -lm
   ld: fatal: library -lrrd_private: not found
   ld: fatal: File processing errors. No output written to tclrrd.so
   make[1]: *** [tclrrd.so] Error 1
   make[1]: Leaving directory `/opt/local/source/rrdtool-1.0.17/tcl'
   make: *** [all-recursive] Error 1
   $ # failure

and temporarily worked around it with this kludge:

   $ find . -name '*private*' -print
   $ cd src/.libs
   $ ln -s librrd_private.al librrd_private.a # kludge
   $ make
   $ # success!

It seems like a problem with the introduction of libtool, but since I'm
not really familiar with "libtool" yet, I've yet to generate a proper
fix for this to submit to Tobi...  perhaps others can help.


plonka at doit.wisc.edu  http://net.doit.wisc.edu/~plonka  ARS:N9HZF  Madison,

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users

More information about the rrd-users mailing list