[rrd-users] Re: HELP: Compile on HP-UX 10.20

Nathan Harris nathan at psicat.com
Mon Nov 27 22:49:18 MET 2000

Nice to hear that there is hope...  I'm trying to build from the latest
rrdtool-1.0.28 tar ball.

I'm using the following packages under HP-UX 10.20 (from the HP porting

           -- plus --

After the swinstalls, I modified my /etc/PATH to include all the /opt/*/bin
directories of the packages above.  I have installed these packages on a
virgin machine (no Softbench or other HP compilers installed) and still no

Did you use the HP porting center's packages?  Or did you build
gcc/binutils/perl from scratch?  Am I missing something I need to get the
compile working?

How did you configure?  I have tried a few ways...

sh ./configure --prefix=/opt/rrdtool-1.0.28
sh ./configure --prefix=/opt/rrdtool-1.0.28 --enable-shared

With the above configurations, I get problems when building the perl-shared
subdirectory.  The error is that it cannot find the rrd_private library
(which does appear to be at ../src/.libs).  The '--enable-shared' flag does
not seem to make a difference in getting this error.  Specifically, from the
perl-shared directory, I run a gmake and get the following:

LD_RUN_PATH="" ld -o blib/arch/auto/RRDs/RRDs.sl -b -s -a shared
RRDs.o -L../src/.libs/ -lrrd_private -lm
ld: Can't find library for -lrrd_private
gmake: *** [blib/arch/auto/RRDs/RRDs.sl] Error 1

Is there something obviously wrong here that I'm missing?


Nathan Harris
P-Com, Inc.

----- Original Message -----
From: "Kurt Andersen" <kurta at spk.agilent.com>
To: <nathan at psicat.com>
Sent: Monday, November 27, 2000 3:14 PM
Subject: Re: [rrd-users] HELP: Compile on HP-UX 10.20

> "Nathan Harris" <nathan at psicat.com> wrote:
> > After searching the mail list archives, it does not appear
> > that anyone has been able to compile RRDtool under HP-UX
> > 10.20 (or 11.00) with much success.  I have been hacking at
> > it for about a week now with little success.  I have tried
> > all the gcc stuff (plus HP Softbench with ANSI C compiler).
> > No combination seems to work.
> >
> > Has anyone had success compiling under HP-UX?
> >
> > Thanks in advance,
> I had no particular problem building it with gcc 2.95.2 on either
> 10.20 or 11.x.  I build the 1.0.26 straight out of the tgz-box.
> --Kurt
> --
> Kurt Andersen <kurta at spk.agilent.com>
> Agilent Technologies Postmaster
> Global Messaging Team, Agilent Technologies
> (509) 921-3792

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list