[rrd-users] stdout with mod_perl and rrdtool

Osmo Paananen Osmo.Paananen at sonera.com
Fri Sep 8 14:42:23 MEST 2000


I'm using rrdtool as perl shared module with mod_perl.

It seems that if I supply "-" as the name of the output graph name
the data won't end up to the socket returned by apache.

If I run the perl script as CGI then all works fine.

If I run apache with -X flag, I get the PNG I wanted to
the window where I started the server.

I'm not fully aware whose problem this is.  Should I blame apache, mod_perl
or rrdtool?

Any ideas how to fix this?

  Osmo Paananen <Osmo.Paananen at sonera.com>            Tel: +358 2040 72263
  Systems specialist, Sonera Online Services / Internet Service Production

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list