[rrd-users] RRD on Mainframe

Carlos Eduardo P. Guidugli carlos_guidugli at hotmail.com
Wed Apr 25 19:37:48 MEST 2001

Hello All,

I'm new to this list and I am trying to compile RRDTool on a mainframe running SuSe 7.0 linux. When I run "sh configure" I get the following output:

------- BEGIN ----------
loading cache ./config.cache
checking host system type... Invalid configuration `s390-unknown-linux-gnu': machine `s390-unknown' not recognized

checking target system type... Invalid configuration `s390-unknown-linux-gnu': machine `s390-unknown' not recognized

checking build system type... Invalid configuration `s390-unknown-linux-gnu': machine `s390-unknown' not recognized

checking for a BSD compatible install... (cached) /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking for perl... (cached) /usr/bin/perl
checking for shared library extension... so
checking for tclConfig.sh in ... no
configure: warning: tclConfig.sh not found - Tcl interface won't be built
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for ranlib... (cached) ranlib
checking for ld used by GCC... (cached) /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... (cached) yes
checking for BSD-compatible nm... (cached) /usr/bin/nm -B
checking whether ln -s works... (cached) yes
loading cache ./config.cache within ltconfig
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed
------------ END -------------

I tried to get the makefile, libtool and config.status from an intel linux and run "config.status" and then run "make" and it worked fine except that I am getting some weird graphics. Does someone know how can I compile RRDTool on a mainframe?

Thanks in Advance,

Carlos Guidugli

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list