[rrd-users] Unexplained NaN's All over the show...

Andrew Kempe andrewk at is.co.za
Sat Feb 17 13:21:16 MET 2001

I've been attempting to input 286 readings into an rrd database but keep
getting unexplained NaN all over the show.

My data is the amount of data output by a device. The amount is read every
300 seconds and written to a file. The readings are timestamped in multiples
of 300 - meaing the timestamps are always valid and exactly 300 seconds
apart. The counter of the device is then reset to 0 after each reading.

So I could have values as follows:


My rrd is created in the following way:

rrdtool create C:\rrdtool\test.rrd --start 982324800 \
--step 300 DS:bitsIn:GAUGE:600:0:U \

I then proceed to update the rrd with the following data:


My timestamps are exactly 300 seconds apart. Every single reading has a
valid timestamp - so there should never be an invalid reading - atleast not
due to an invalid timestamp.

Yet when you dump the rrd to xml, there are rows with NaN in them. Eg:

<!-- 2001-02-16 20:45:00 South Africa Standard Time --> 
	<row><v> 1.9884600000e+006 </v></row>
<!-- 2001-02-16 20:50:00 South Africa Standard Time --> 
	<row><v> NaN </v></row>
<!-- 2001-02-16 20:55:00 South Africa Standard Time --> 
	<row><v> NaN </v></row>
<!-- 2001-02-16 21:00:00 South Africa Standard Time --> 
	<row><v> NaN </v></row>
<!-- 2001-02-16 21:05:00 South Africa Standard Time --> 
	<row><v> 2.2503400000e+006 </v></row>

I can't seem to see why the data being input is invalid. Am I doing
something wrong when it comes to creating the database? I've tried creating
the rrd as a GUAGE, ABSOLUTE, COUNTER etc etc but I still get these invalid
entries. I've even tried writing a simple application that has two counters,
one for time and one for a value. They are incremented by 300 and 1
respectively. So the data is totally symetrical. Yet when I upate the rrd it
continues to have NaN's all over the show.

Any help would be appreciated!!

Thanks, Andrew

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list