[rrd-users] One other quickie :-D

Mohammed Burney rockit at wam.umd.edu
Tue Jun 26 03:20:22 MEST 2001

Hello all,

Thanks to those of you that replied to my question. It really helped, heck
it fixed my problem :-)
My other problem that I wasn't able to get my perl scripts that update the
RRD to run thru cron. I tried 2-3 different approaches.

1) Tried using the 'use RRDs' method, and invoke the updates as Perl
2) Make a system call to update the RRD `rrdtool update ...`
3) use pipe to update the RRD "./perl_script | rrdtool -

All of these methods work independently, meaning that if I run them thru the
command line, I have no problems. It is just when I run them thru cron that
nothing happens. I'm running as root, in Mandrake 7.2 from the / directory.
I asked around and people told me to try and give absolute path names, which
I did, and still nothing happened.

Thanks once again :-)

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list