[rrd-users] Having problems with rrdtool-1.0.37 restore

Andrew Levine andrew_levine at verestar.com
Tue Apr 16 01:49:29 MEST 2002

Hello All,

I recently encountered a segfault issue with the most recent rrdtool-1.0.37
"restore" option.

Here is what happened:

After doing the following:
$> /usr/local/rrdtool-1.0.37/bin/rrdtool dump datafile.rrd >in.xml

Then not altering "in.xml" in any way, I ran:
$> /usr/local/rrdtool-1.0.37/bin/rrdtool restore in.xml datafile.rrd
Segmentation fault

- then:
$> /usr/local/rrdtool-1.0.37/bin/rrdtool restore in.xml datafile2.rrd

That worked.

With older versions of rrdtool, an existing .rrd file could be written
over with the "restore" function.

Was the most recent build of rrdtool suppose to be like this?  If
so, sorry to take up your time.

For some background information, I used two linux machines to test
this.  Both had rrdtool-1.0.35 and rrdtool-1.0.37 built on them.

Machine 1 is a Redhat 6.1 build:
$> gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)

Machine 2 is a Redhat 7.2 build:
$> gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)

When I use the rrdtool-1.0.35 build on each machine, the "restore"
function wrote over the original .rrd file.


andrew_levine at verestar.com           Managing System Administrator
Verestar (Santa Monica)                    http://www.verestar.com
1901 Main St.                                   tel (310) 382 3300
Santa Monica, California 90405                  fax (310) 382 3310

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list