[rrd-users] Code change request: Longer DS names please!

rik rik+rrdtool at little-black-kitty.net
Mon Jul 15 02:26:38 MEST 2002


I'm working on mapping in-kernel data structures which contain counters
onto DSs in a single RRD, depending on the area of the kernel. The
easiest way I can think of is to hash the static part of the structure,
and use the ASCII representation of that.

In order to accomplish this, and keep a modicum of sanity, I would
appreciate it if the length of a DS could be extended, to 33 bytes. This
would then hold the ASCII-printable MD5 checksum of arbitrary data.
This would provide a standard way for anyone to map to a DS name in an

I have made a patch, which is at the end of this message. Please note I
haven't tested it, or verified that these are the only values that need


--- rrd_format.h        Wed May 22 18:07:21 2002
+++ /tmp/rrd_format.h   Mon Jul 15 01:07:34 2002
@@ -151,7 +151,7 @@

 /* The magic number here is one less than DS_NAM_SIZE */
 #define DS_NAM_FMT    "%19[a-zA-Z0-9_-]"
-#define DS_NAM_SIZE   20
+#define DS_NAM_FMT    "%32[a-zA-Z0-9_-]"
+#define DS_NAM_SIZE   33
 #define DST_FMT    "%19[A-Z]"
 #define DST_SIZE   20

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list