[rrd-users] Re: PROBLEM: RRDTOOL and MRTG

John M. Campbell JohnMCampbell at Jabil.com
Mon Mar 25 21:14:49 MET 2002

Nevermind...  With the help of the other email (Thread: First rrd gets only
"nan" data with fetch") and the documentation, I have figured out that it is
working.  I am just trying to look at the data before the end of my

I was noticing that the data was not coming out if I update it within the
heartbeat, but if I record it at a set interval (step), it does show the

MRTG is working great now!  Now I can get it off my Windows server and onto
a Linux server!!!

Thank you all!

-----Original Message-----
From: John M. Campbell [mailto:JohnMCampbell at Jabil.com]
Sent: Friday, March 22, 2002 12:39 PM
To: 'rrd-users at list.ee.ethz.ch'
Subject: [rrd-users] PROBLEM: RRDTOOL and MRTG

I am having a problem.  I have installed RRDTOOL 1.0.34 and MRTG 2.9.18pre2
on a Linux box.

Everything looks like it runs fine, except when I query the data (using
RRDTOOL FETCH), it comes back with NAN for every value.

I tried it with existing MRTG logs, and it converts fine.

I tried it with no logs, and it creates the RRD files fine.

The MRTG log file shows that it does the tune, update, last, and fetch, but
the log shows that "got: / ".  The update is actually updating the data with

The RRDTOOL LAST function returns the correct updated date that was entered.

I have found that if I do an update with a time that is in the database
("1016817300:25:25" for instance), it can be fetched.

Is there a problem somewhere, or have I just misconfigured something, or
should I go back and get a previous version of MRTG?

Thank you,
John M. Campbell
IT Manager
Jabil Global Services, Inc.
Louisville, Kentucky

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list