[rrd-users] Re: rrdtool-1.0.39 on Solaris 6 : configure error

Boismartel, Jerome jerome.boismartel at cantrex.com
Tue Sep 3 21:51:10 MEST 2002

Hi Gerhard,

Thank you for your help. I must tell you that I looked at the archives... As
I could not find anything really usefull for my issue, I decided to post my
Anyway, I have found the problem. And I think this might interest other
Solaris/perl/rrdtool users.
I could not see where the error "./configure: test: unknown operator
-B/usr/ccs/bin/" came from. Was it GCC or Perl ? Well in fact it is perl.
I took the Perl package from sunfreeware site. This package includes a
compiled version of perl 5.8.0. The issue is that it was configured and
compiled with the following option :
-Dcc='gcc -B/usr/ccs/bin/'
For a reason that I cannot explain, Configure from rrdtool sources takes
that variable and try to pass it to the "test" programm. This one does not
recognise the -B argument.

The work around is to get source code of perl, configure and compile it
without the parameter (-B) :
sh Configure -Dcc='gcc' 

Becarefull : During perl configuration questions, you will have to make sure
gcc -B/a/path/ does not show up. It did in mine... In such case, just
replace with 'gcc'.

Once perl is compiled and installed, we can configure/compile/install

To make this complete, here is my env variables :
echo $PATH


-----Message d'origine-----
De: Gerhard Ecaroh Froehlich
[mailto:gerhard.froehlich at produktion.gis-online.de]
Date: September 2, 2002 4:18 AM
À: Boismartel, Jerome
Cc: 'rrd-users at list.ee.ethz.ch'
Objet: Re: [rrd-users] rrdtool-1.0.39 on Solaris 6 : configure error

Hi Jerome,

"Boismartel, Jerome" wrote:
> Hello,
> When I run sh configure on my system I have the following error :
> checking for the C compiler perl wants to use to build its modules...
> ./configure: test: unknown operator -B/usr/ccs/bin/
> I run Solaris 6 and perl 5.8.0
> Does anyone run into this issue ? What was the solution ?

One solution is to read the archives. The question was asked multiple only
ago. In short: Install all GNU Tools and GCC, including correct settings of
$PATH. This should help, cause Solaris don't compile that good.

> =------------------------------------------------------------=
> Jerome Boismartel


Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list