[rrd-users] rrdtool-1.0.4 compilation

Pierre-Etienne.Kaluzny at kabira.fr Pierre-Etienne.Kaluzny at kabira.fr
Thu Feb 27 15:51:37 MET 2003


I know this subject is not really appealing; however, when I run make for 
rrdtool-1.0.4, I get an error on a solaris8 machine.

This solaris8 machine hasthe following packages installed in /usr/local:
#pkginfo | grep SMC
application SMCautoc       autoconf
application SMCautom       automake
application SMCgcc302      gcc
application SMClibt        libtool
application SMCmake        make
application SMCperl5.0.8        perl

# echo $PATH
# make
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../config  
  -g -O2 -Wall -pedantic -Wshadow -Wpointer-arith -Wcast-align 
-Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline 
-fPIC -c infblock.c
gcc -DHAVE_CONFIG_H -I. -I. -I../config -g -O2 -Wall -pedantic -Wshadow 
-Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations 
-Wnested-externs -Winline -fPIC -c infblock.c -o infblock.o
/usr/ccs/bin/as: "/var/tmp/ccimLsWE.s", line 1654: error: unknown opcode 
/usr/ccs/bin/as: "/var/tmp/ccimLsWE.s", line 1654: error: statement syntax
/usr/ccs/bin/as: "/var/tmp/ccimLsWE.s", line 1667: error: unknown opcode 
/usr/ccs/bin/as: "/var/tmp/ccimLsWE.s", line 1667: error: statement syntax
make[1]: *** [infblock.lo] Error 1
make[1]: Leaving directory 
make: *** [all-recursive] Error 1

Even if /usr/ccs/bin/make is found before /usr/local/bin/make (by changing 
$PATH) , I get the same error.

Any idea will be appreciated.



Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list