[rrd-users] Re: Help with running remstats

gab.seun jones.ewulomi seun_ewulomi at hotmail.com
Wed Mar 12 16:10:17 MET 2003

Hi Thomas,

1)My web-server is run as root? How do I change it otherwise

2)I did as you suggested. I went into the directory where unpacked it 
remstats and typed
"make owner"

3)Yes I did create a remstats user. I have also created a host config 
file(by your direction) using "new-config".
which then created the pseudo-host _remstats_
4) I then tried to use the "new-ping-hosts" to create a host. Im I using the 
"new-ping-hosts" in the correct way. can you help if possible.

(output below)
./new-ping-hosts -d -f /var/remstats/etc/config/ 
Argument "-f" isn't numeric in numeric gt (>) at 
/var/remstats/lib/remstats.pl line 2715, <FILE> line 1.
DEBUG: unknown host aberdeen; attempting to continue
DEBUG: unknown host bristol; attempting to continue

/var/remstats/etc/config/hostnames = the file that contains hostnames

this however created a host in the /var/remstats/etc/config/hosts directory 
called aberdeen and bristol. But they didnt look right. I then edited with 
the correct ip address, group etc

5)I then tried to run "run-remstats" logging in as remstats user (su - 
remstats). But I get the error below

Thank you very much for your reply.
[root at remstats-server bin]# ./run-remstats

Errors from ping-collector:

defined(@array) is deprecated at /var/remstats/bin/ping-collector line 75.
        (Maybe you should just omit the defined()?)

Errors from port-collector:

defined(@array) is deprecated at /var/remstats/bin/port-collector line 75.
        (Maybe you should just omit the defined()?)

Errors from snmp-route-collector:

defined(@array) is deprecated at /var/remstats/bin/snmp-route-collector line 
        (Maybe you should just omit the defined()?)
6)The version of remstats Im running is remstats-1.00a4
I was using the latest version(remstats-1.0.9b) but decided to drop down to 
the 1.00a4 version because I was getting to many errors.

My apologies on the long reply. But your help or anyones help will be 
greatly appreciated


>From: Thomas Erskine <thomas.erskine at sympatico.ca>
>To: "gab.seun jones.ewulomi" 
><seun_ewulomi at hotmail.com>,rrd-users at list.ee.ethz.ch
>Subject: [rrd-users] Re: Help with running remstats
>Date: Wed, 12 Mar 2003 05:57:21 -0500
>At 05:17 2003-03-11, gab.seun jones.ewulomi wrote:
>  >Hi,
>  >
>  >Can anyone help me. I cant seem to get remstats to work. Iv followed the
>  >documentation in and out and I still dont know what is wrong.
>  >
>  >Any help will be greatly appreciated
>  >
>  ><<<<<<Error below>>>>>>>>>>>>>
>  >[root at remstats-server bin]#  /usr/bin/run-remstats
>You're going to have problems running remstats as root.  You don't run your
>web-server as root do you?  Go back to the directory where you unpacked it
>and , as root, type "make owner".  Then only run remstats programs as the
>remstats user.  I'm assuming that you did create one.
>  >run-remstats: ERROR: put_status: directory /var/remstats/data/_remstats_ 
>  >missing; skipped
>This will happen if you don't have a host config file for the pseudo-host
>_remstats_.  Since "new-config" will create this, I don't know how you
>avoided getting it created?  How did you create your configuration
>directory?  Did you use "new-config /var/remstats/etc/config" or wherever
>you told it to expect configuration directories?  Which version of remstats
>are you installing from?


Stay in touch with MSN Messenger http://messenger.msn.co.uk

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list