[rrd-users] RRDtool compile error on Solaris 9

Asif Iqbal iqbala-rrd-users at qwestip.net
Tue Feb 8 01:36:10 MET 2005

Hi All

I saw lot of people having trouble compiling rrdtool-1.0.49 on Solaris 9. 
I am having the exact same problem. I am using gcc 3.4.1, perl 5.6.1. I
tried perl -V:cc as both /usr/ucb/cc and /usr/local/bin/cc --> gcc. Exact
same error.

/bin/bash ../libtool --mode=link gcc  -g -O2 -Wall -pedantic -Wshadow
-Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations
-Wnested-externs -Winline   -o librrd_cgi.la   cgi.lo  -lm

false cru .libs/librrd_cgi.a  cgi.o

gmake: *** [librrd_cgi.la] Error 1

I noticed there is no file--not even any dot file--in the .libs dir
under /usr/share/src/rrdtool-1.0.49/cgilib-0.4

I am wondering if someone found a workaround for this.

Any help/feedback would be greatly appreciated.

Asif Iqbal
PGP Key: 0xE62693C5 KeyServer: pgp.mit.edu
"...it said: Install Windows XP or better...so I installed Solaris..."

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-users mailing list