[rrd-users] RE : Dump from rrd 1.0.x and restore to rrd 1.2.x

FIGARO Nicolas nfigaro at effigie.fr
Tue Jul 19 10:58:08 MEST 2005

I tried this solution (using rrdtool 1.0 to dump and rrdtool 1.2 to restore), 
But I still receive the message : 
ERROR: This RRD was created on other architecture. 


-----Message d'origine-----
De : Andreas Maus [mailto:a.maus at science-computing.de] 
Envoyé : mardi 19 juillet 2005 10:48
À : FIGARO Nicolas
Objet : Re: [rrd-users] Dump from rrd 1.0.x and restore to rrd 1.2.x

On Tue, Jul 19, 2005 at 09:46:06AM +0200, FIGARO Nicolas wrote: Hi Nicolas.

> I'd like to "convert" an rrd file from 1.0.x to 1.2.x format.
Hmmm ... I am not sure but do you _really_ have to dump/restore a database created with 1.0.x to use it with 1.2.x ?

> I tried to dump to xml and restore, but I still have error message 
> about different architectures.
Can you show us how do you dump and restore?


rrdtool dump oldarchitecture.rrd > oldarchitecture.xml
rrdtool restore oldarchitecture.xml newarchitecture.rrd

Will usually do the trick.

So long,



Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list