[rrd-users] Re: RRD with historical data

Alex van den Bogaerdt alex at ergens.op.het.net
Tue Oct 18 16:50:05 MEST 2005

On Tue, Oct 18, 2005 at 04:15:04PM +0300, Dez Cadena wrote:

> > rrdtool -b <start date>
> > 
> > Make sure you update with <epoch time>:value i.s.o. N:value.
> > 
> > Serge.
> I tried this:
> rrdtool create test.rrd -b now-10d -s 86400 DS:msgs:ABSOLUTE:86400:U:U RRA:AVERAGE:0.5:1:10
> and then
> rrdtool update test.rrd 1128643200:100
> which returned
> ERROR: illegal attempt to update using time 1128643200 when last update time is 1128776944 (minimum one second step)

"Now" equals 1129646727, subtract 10*86400 to get 1128782727.
The difference with your 1128776944 is because you tried earlier.

Then you update using 1128643200 which is before 1128776944.

What you need is a database that starts before the first update
you are going to submit.  Start does not have to be an exact multiple
of 86400 but rrdtool is, internally, going to do that anyway. Why not
do that yourself...

So, rrdtool create test.rrd -b 1128556800 -s 86400 DS:msgs:ABSOLUTE:86400:U:U RRA:AVERAGE:0.5:1:10
and do adjust that RRA length if you need more than 10 days.

Alex van den Bogaerdt

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list