[rrd-users] Problem compiling RRDs perl module under Solaris 9

nobody cot39070-forumaccount at fh-regensburg.de
Thu Sep 8 17:41:53 MEST 2005

Hi all,

i am using Solaris 9 (GCC 3.3.1)  and i  want to use MRTG with the 
RRDTool, but i have a Problem compiling the RRDTOOL.
Configure throws the following message:

I would not find the Compiler (cc) that was originally used to compile
your perl binary. You should either make sure that this compiler is
available on your system, pick an other compiler and set PERLCC
appropriately, or use a different perl setup that was compiled locally.

I will disable the compilation of the RRDs perl module for now.

Config is DONE!

         With MMAP IO: yes
         Perl Modules: perl_piped
          Perl Binary: /usr/bin/perl
         Perl Version: 5.6.1
         Perl Options: PREFIX=/soft/rrdtool-1.2.11 
         Build Tcl Bindings: no 
         Build Python Bindings: no
         Build rrdcgi: yes
         Build librrd MT: yes


1) I dont want to install the the Solaris compiler
2) I dont want to compile Perl with GCC again
3) So i decided to download Solaris-PerlGcc-1.3 to create the Perl Modules.

But if i run ...

cd /opt/apps/rrdtool-1.2.11/bindings/perl-shared
perlgcc Makefile.PL

the following Error occurs:

Can't locate ExtUtils/MM.pm in @INC (@INC contains: 
/usr/perl5/5.6.1/lib/sun4-solaris-64int /usr/perl5/5.6.1/lib 
/usr/perl5/site_perl/5.6.1/sun4-solaris-64int /usr/perl5/site_perl/5.6.1 
/usr/perl5/site_perl /usr/perl5/vendor_perl/5.6.1/sun4-solaris-64int 
/usr/perl5/vendor_perl/5.6.1 /usr/perl5/vendor_perl .) at 
/usr/perl5/site_perl/5.6.1/Solaris/PerlGcc/ExtUtils/MakeMaker.pm line 34.
Compilation failed in require at Makefile.PL line 1.
BEGIN failed--compilation aborted at Makefile.PL line 1.

There is no MM.pm on my Maschine! I tried:    find / -name MM.pm

Can anybody say me pleaseeeeeeeeee whats going wrong?

Thanks a lot


Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list