[rrd-users] Re: RRDTool with Darwin 10.4

Mark Duling mark.duling at biola.edu
Fri Sep 16 17:26:25 MEST 2005


I don't fully understand the problem, especially if you are getting
rrdtool error messages and you don't think you're using it.  But, at the
risk of inviting charges of heresy, why don't you just ditch MRTG?  I
think it's time has come and gone.  I didn't use it precisely because I
didn't fully understand how it worked, or at least I thought it was
complex or inelegant enough that I didn't care.  No offense, but it sounds
like you may be in over your head.  I've been there many times.

I'm on OS X 10.4 also, and I run NRG, an RRDtool frontend.  It is a
DarwinPorts package now and it installs NRG, the latest RRDtool and all
dependencies automatically with one command.  Then you just edit one file
and put your switches and routers in it and it creates your graph config
files and manages the web pages automatically.  Take a look and see if it
might be easier to learn a more modern SNMP grapher than to learn what's
wrong with your old one.  Here's a HOWTO if it helps:


Evan Platt <evan at espphotography.com> on Friday, September 16, 2005 at 6:56
AM -0800 wrote:
>At 12:37 AM 9/16/2005, you wrote:
>>unfortunately your lack of information will prevent anyone from
>>assisting you.
>Tell me what's needed. My mrtg.cfg file? Mrtg runs fine normally 
>(without rrdtool enabled).
>Here's my mrtg.cfg file:
>LibAdd: /opt/local/lib/perl5/site_perl/5.8.7/darwin-2level/
>LibAdd: /usr/local/rrdtool-1.2.11/bindings/perl-shared
>PathAdd: /opt/local/bin/
>Unscaled[]: YMDW
>Options[_]: growright
>Target[]: 2:public at
>#SetEnv[]: MRTG_INT_IP="" 
>MRTG_INT_DESCR="VIA Rhine II Fast Ethernet Adapter #2
>#SetEnv[]: MRTG_INT_IP=""
>MaxBytes[]: 600000
>Title[]: Traffic Analysis for 65542 -- DESKTOP
>PageTop[]: <H1>Traffic Analysis for 65542 -- DESKTOP</H1>
>  <TABLE>
>    <TR><TD>System:</TD>     <TD>www.espphotography.com</TD></TR>
>    <TR><TD>Maintainer:</TD> <TD>evan at espphotography.com</TD></TR>
>    <TR><TD>Max Speed:</TD>  <TD>6.0 MBPS</TD></TR>
>  </TABLE>
>WorkDir: /Library/WebServer/Documents/mrtg
>>I'm running 10.4 and have no issued with rrdtool.
>I can't get either of those pages to come up....

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list