[rrd-users] Installation Problems - no cgilib.pc file

richard kennard richard.kennard at oxfordgenomesciences.com
Mon Sep 26 14:45:29 MEST 2005

Dear All,
I've seen this problem before on the list and via google but havn't been 
able to make much progress with other posted solutions.

I'm trying to install RRDtool-1.2.10 on a fedora core 4 box. (The 
install is the 'complete' type with all the files etc)
I'm following the rrdbuild install notes.

When I do the ./configure --prefix=$INSTALL_DIR && make && make install 
I get:

configure: WARNING:
* I found a copy of pkgconfig, but there is no cgilib.pc file around.
  You may want to set the PKG_CONFIG_PATH variable to point to its
configure: WARNING:
* I could not find a working copy of cgilib. Check config.log for hints 
on why
  this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
  so that compiler and the linker can find libcgi and its header files.  

I've tried downloading and recompiling cgilib to no avail.
I've also noticed that there is not cgilib.pc file (so no surprise the 
install counldn't see it..) , so have tried manually creating one 
following advice on the cactus list:

The file contents of my cgilib.pc look like this:

Description: Common Gateway Interface (CGI) Library
Libs: -L${libdir} -lcgi
Cflags: -I${includedir}

and is in

I've also tried  LDFLAGS to no avail, but as NIX is not my first 
language I'm not convinced that I'm setting LD/CPPFlags correctly.

Can anyone help me get back on track please?



Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list