[rrd-users] start end format YYYYMMDDhhmm fails in win 1.2.10 and linux 1.2.12

Nick Sharp njsharp at bigpond.net.au
Thu Feb 16 01:21:12 MET 2006

I feel from the documentation that this SHOULD be valid code:

C:\usr>rrdtool graph test.png -w 800 -h 200 -s 200602151000 -e 200602151800 
DEF:frs=nfhauhq.rrd:frs:AVERAGE DEF:seq=nfhauhq.rrd:seq:AVERAGE AREA:frs#00FF00:"Flow Records" 
LINE1:seq#0000FF:"Sequence Number"

I see examples of datetime values just like the above YYYYMMDDhhmm format.  EG:
January 2001:    --start 200101010000 --end 200102010000

(Yes. I tried both -s -e and --start --end)

but windows rrdtool 1.2.10 said:

ERROR: start time: did you really mean month -1261311912?

So I converted the datetime values to unixtime:

C:\usr>rrdtool graph test.png -w 800 -h 200 -s 1139958000 -e 1139986800 
DEF:frs=nfhauhq.rrd:frs:AVERAGE DEF:seq=nfhauhq.rrd:seq:AVERAGE AREA:frs#00FF00:"Flow Re
cords" LINE1:seq#0000FF:"Sequence Number"

On windows 1.2.10 I got:

ERROR: This RRD was created on other architecture (indeed! Fedora Core 4!)

so I moved the unixtime version test to Fedora Core 5 test 2 + rrdtool 1.2.12 which did that graph 

When I tried the first version on FC5t2/1.2.12 instead of a complaint about the time, it went into a 
CPU-shredding loop, using up all the spare.

Nick Sharp

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list