[rrd-users] anti-aliasing rrdtool 1.2 seemingly not working

Emmett Keyser Emmett.Keyser at sf.tribalddb.com
Mon Nov 13 02:35:12 MET 2006

Hello all,
It is with some hesitancy that I post to this list because the problem
I'm having seems like it would be pretty common or that I'm not using a
command line switch of some sort. Unfortunately, I've been researching a
solution for some 4 days and have yet to find anything. Hopefully,
someone can point me in the right direction.
The problem is straightforward: my graphs aren't being generated with
anti-aliasing. And here's some relevant information:
Red Hat Enterprise Linux 4
my latest try has gone the route of manually compiling:
Some background:
Here is the output to the dependencies for rrdtool (and perl-rrdtool):
[root at emmett ~]# rpm -R -ivh --test rrdtool-1.2.15-1.el4.rf.i386.rpm
warning: rrdtool-1.2.15-1.el4.rf.i386.rpm: V3 DSA signature: NOKEY, key
ID 6b8d79e6
error: Failed dependencies:
        perl(RRDp) is needed by rrdtool-1.2.15-1.el4.rf.i386
        perl(RRDs) is needed by rrdtool-1.2.15-1.el4.rf.i386
[root at emmett ~]# rpm -R -ivh --test
warning: perl-rrdtool-1.2.15-1.el4.rf.i386.rpm: V3 DSA signature: NOKEY,
key ID 6b8d79e6
error: Failed dependencies:
        /usr/bin/rrdcgi is needed by perl-rrdtool-1.2.15-1.el4.rf.i386
        librrd.so.2 is needed by perl-rrdtool-1.2.15-1.el4.rf.i386
        rrdtool = 1.2.15 is needed by perl-rrdtool-1.2.15-1.el4.rf.i386
But when I try to install both perl-rrdtool and rrdtool at the same time
I don't get any dependency issues - don't know if that's okay or not -
it just seems weird that each depends on the other.
Now when I tried the route of manually installing rrdtool I got
dependency issues with libpng, libart, and freetype. This seemed natural
so I downloaded and compiled those packages. I finally tried compiling
rrdtool and ran into a problem with tcl so I did --disable-tcl for the
configuration and it compiled fine.
After the manual compile things are the same.
My next step is to go through the source code of cacti to see exactly
how the graphs are being generated there in hopes that I'm just missing
a simple switch on the command line for "rrdtool graph" which by the way
is the following:
/usr/local/rrdtool/bin/rrdtool graph 000d610a8677_cpu01.png
DEF:ds0a=000d610a8677_cpu01.rrd:cpu01:AVERAGE AREA:ds0a#999999:"percent
cpu load\\n" -v "%" -a PNG -l 0 -u 100 -t "PROCESSOR UTILIZATION"  -h
200 -w 600
Any help would be greatly appreciated.
Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list