[rrd-users] Problems - Solaris 10 Install

wilsonlcj at brturbo.com.br wilsonlcj at brturbo.com.br
Tue Nov 28 12:29:26 MET 2006

Thank you MrPaul, 
     in fact the error is ocurring at the link fase, follow the make result and a partial copy of feature_tests.h , where the error is generate. The version of gcc is:
 gcc --version
 sparc-sun-solaris2.10-gcc (GCC) 4.0.3 (gccfss)
make  all-recursive
make[1]: Entering directory `/export/home/wilson/rrdbuild'
Making all in src
make[2]: Entering directory `/export/home/wilson/rrdbuild/src'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/export/home/wilson/rrdbuild/src'
Making all in bindings
make[2]: Entering directory `/export/home/wilson/rrdbuild/bindings'
Making all in python
make[3]: Entering directory `/export/home/wilson/rrdbuild/bindings/python'
if gcc -DHAVE_CONFIG_H -I. -I. -I../..  -g -O2 -fno-strict-aliasing -Wall -std=gnu99 
-pedantic -Wshadow -Wpointe
r-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations -Wnested-externs 
-Winline -W  -fPIC -DPIC -I../
../src -I/usr/sfw/include/python2.3 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT 
-I/usr/include/libart-2.0 -I/usr/inc
lude/freetype2 -I/usr/sfw/include/freetype2    -g -O2 -fno-strict-aliasing -Wall 
-std=gnu99 -pedantic -Wshadow -
Wpointer-arith -Wcast-align -Wmissing-prototypes -Wmissing-declarations -Wnested-externs 
-Winline -W  -fPIC -DPI
C -MT rrdtoolmodule.o -MD -MP -MF ".deps/rrdtoolmodule.Tpo" -c -o rrdtoolmodule.o 
rrdtoolmodule.c; \
then mv -f ".deps/rrdtoolmodule.Tpo" ".deps/rrdtoolmodule.Po"; else rm -f 
".deps/rrdtoolmodule.Tpo"; exit 1; fi
In file included from /usr/include/limits.h:18,
                 from /opt/gcc/lib/gcc/sparc-sun-solaris2.10/4.0.3/include/limits.h:122,
                 from /opt/gcc/lib/gcc/sparc-sun-solaris2.10/4.0.3/include/limits.h:11,
                 from /usr/sfw/include/python2.3/Python.h:19,
                 from rrdtoolmodule.c:42:
/opt/gcc/lib/gcc/sparc-sun-solaris2.10/4.0.3/include/sys/feature_tests.h:341:2: error: 
#error "Compiler or options invalid for pre-UNIX 03 X/Open applications  and pre-2001 
POSIX applications"
make[3]: *** [rrdtoolmodule.o] Error 1
make[3]: Leaving directory `/export/home/wilson/rrdbuild/bindings/python'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/export/home/wilson/rrdbuild/bindings'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/home/wilson/rrdbuild'
make: *** [all] Error 2
and at line 341 of feature_tests.h 
   333  /*
   334   * It is invalid to compile an XPG3, XPG4, XPG4v2, or XPG5 application
   335   * using c99.  The same is true for POSIX.1-1990, POSIX.2-1992, POSIX.1b,
   336   * and POSIX.1c applications. Likewise, it is invalid to compile an XPG6
   337   * or a POSIX.1-2001 application with anything other than a c99 or later
   338   * compiler.  Therefore, we force an error in both cases.
   339   */
   340  #if defined(_STDC_C99) && (defined(__XOPEN_OR_POSIX) && !defined(_XPG6))
   341  #error "Compiler or options invalid for pre-UNIX 03 X/Open applications \
   342          and pre-2001 POSIX applications"
   343  #elif !defined(_STDC_C99) && \
   344          (defined(__XOPEN_OR_POSIX) && defined(_XPG6))
   345  #error "Compiler or options invalid; UNIX 03 and POSIX.1-2001 applications \
   346          require the use of c99"
   347  #endif
Thank you in advance
----- Mensagem Original -----
De: MrPaul <mrpaular at gmail.com>
Data: Segunda-feira, Novembro 27, 2006 14:58
Assunto: [rrd-users] Re: Problems - Solaris 10 Install
Para: "wilsonlcj at brturbo.com.br" <wilsonlcj at brturbo.com.br>
Cc: rrd-users at list.ee.ethz.ch
> On 11/27/06, wilsonlcj at brturbo.com.br 
> <wilsonlcj at brturbo.com.br> wrote:
> >
> > Hello,
> >      Everything is going fine, except 
> the installation of  RRDTool, I've
> > tried to compile it, but didn't work (I tried many time, call 
> for help,
> > etc...).
> The only binary I'm aware of is
> http://www.sunfreeware.com/programlistsparc10.html#rrdtool.  Probably not
> the version you're wanting.
> If you can tell us what error's you're getting during the 
> compile someone
> here may be able to address that for you.
> Paul
> --

Unsubscribe mailto:rrd-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-users mailing list