[rrd-users] Problem with CDEFs, and question about PRINT

David Ball davidtball at gmail.com
Mon Apr 23 21:39:51 CEST 2007

  The Perl script I'm calling system() from does a ton of other stuff
besides generate the graph, so there is a point in this particular
case, but I understand what you mean.
  That said, if/when I get things working the way I want with
system(), perhaps then I'll try RRDs.pm methods I guess.
   Another person pointed out that I should be dividing by 8, and not
multiplying, which is absolutely right, and I had tried earlier, but
had since tried multiplying by 0.125 instead of dividing by 8 in case
it was a matter of the / not properly escaping.

CDEF:totbytes=inbits_tot,outbits_tot,+,0.125,*   and

   aren't working still.  *ponders*


On 4/23/07, Fabien Wernli <wernli at in2p3.fr> wrote:
> On Mon, Apr 23, 2007 at 11:27:22AM -0600, David Ball wrote:
> > divide by 8 to get Bytes.  From the Perl script I'm using a system()
> > call to call rrdtool.  The current system() call line I'm using can be
> You really ought to use the perl bindings. Using system() really makes no
> point in using perl in the first place -

More information about the rrd-users mailing list