[rrd-users] libpng error

Sam Umbach sumbach at gmail.com
Tue Apr 24 02:19:57 CEST 2007

On 4/20/07, jim steele <jsteele1997 at gmail.com> wrote:
> Hello,
> I have successfully built and installed rrdtool-1.2.19 on OpenBSD 4.0
> along with the following libs:
> freetype-2.3.4
> libart_lgpl-2.3.17
> libpng-1.2.16
> zlib-1.2.3
> When I try to create a graph either from a perl script using RRDs or
> from rrdtool graph on the command line, I get this error:
> libpng error: zlib error


Have you tried running the same rrdtool graph command with a different
image format for your output (alternatives are EPS, SVG, and PDF; see
the --imgformat parameter).  If rrdtool can render to these other
formats, that helps narrow down the problem.

Also, follow the tutorial on the rrdtool website.  Are those graphs
rendered or do you receive the same error?  This will help determine
if this is a general problem with the library (or interaction between
librrd, libpng, and zlib) or if it's an inconsistent problem that may
be caused by improper memory allocation, insufficient buffer length,


More information about the rrd-users mailing list