[rrd-users] Invalid RPN -- why? (solved)

Gutza gutza at moongate.ro
Thu Dec 13 11:03:43 CET 2007

Alex van den Bogaerdt wrote:
> On Thu, Dec 13, 2007 at 02:07:08AM +0200, Gutza wrote:
>> I get an "invalid rpn" error message for the following CDEF:
>> CDEF:old=old_percent,user_percent,-,familiar_percent,-,robot_percent,-
> Perhaps there's a typo in this RPN or in one of the DEFs or CDEFs ?
Thank you for pointing me in the right direction, Alex! Indeed, the
problem was a mismatch between DEFs and the RPN atoms -- the cause
however wasn't a typo, but rather lack of attention. I was trying to use
data source names instead of vdefs in the RPN. In other words, I was
doing something of this sort:

rrdtool graph /dev/null \
        DEF:ds1=x.rrd:x:AVERAGE \
        DEF:ds2=x.rrd:y:AVERAGE \

Anyway, problem solved, all is well -- I just wrote this for future


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20071213/c152c434/attachment.html 

More information about the rrd-users mailing list