[rrd-users] Make just stops when compiling on Solaris 10 x86

Jonathan Armitage jon.armitage at hepworthband.co.uk
Thu Jan 25 22:07:54 CET 2007

Alex van den Bogaerdt wrote:
> What happens if you do the following:
> Create a file "/tmp/hello"
> Contents:
>    Hello there
> And then run the following:
>    sed s,Hello,Hi, /tmp/hello > /tmp/hi
> I would expect a file "/tmp/hi" with contents "Hi there".
> If it doesn't work, try:
>    sed s/Hello/Hi/ /tmp/hello > /tmp/hi
> still no go:
>    sed s/Hello/Hi/ < /tmp/hello > /tmp/hi
> still no go:
>    cat /tmp/hello | sed s/Hello/Hi/ > /tmp/hi
> and let the list know.
Sorry for the delay in replying. I've been at work.

Well, the answer is: they all work.

So I created a mini Makefile:

exec_prefix = /usr/local

cgi-demo.cgi : cgi-demo.cgi.in
         sed 's,@''exec_prefix@,$(exec_prefix),' $< > $@

And this is what happened:

-bash-3.00$ make
sed 's,@''exec_prefix@,/usr/local/bin,'  > cgi-demo.cgi
*** cgi-demo.cgi removed.

It hangs waiting for input the same as before. But:

-bash-3.00$ gmake
sed 's,@''exec_prefix@,/usr/local/bin,' cgi-demo.cgi.in > cgi-demo.cgi

works correctly.

So it looks like Solaris make is not figuring out how to make a .cgi 
from a .in. The suffix rules not working correctly?

Serves me right for not typing gmake in the first place.


More information about the rrd-users mailing list