[rrd-users] RRDtool compile problem (fwd)

Teemu Ensio Illikainen t3ilte00 at students.oamk.fi
Thu Jun 28 11:59:48 CEST 2007

---------- Forwarded message ----------
Date: Thu, 28 Jun 2007 12:37:11 +0300 (EEST)
From: Teemu Ensio Illikainen <t3ilte00 at students.oamk.fi>
To: tobi at oetiker.ch
Subject: RRDtool compile problem


I'm trying to install RRDtool to one machine but compiling fails everytime. I 
have followed directly your guide here 
http://oss.oetiker.ch/rrdtool/doc/rrdbuild.en.html and I have already installed 
this to two machine succesfully.

After compiling and installing all needed libraries, I run ./configure in 
rrdtool -directory. It runs OK, but then when I type "make" it starts to 
compile but fails after a while. Here is some last lines of output:

o .libs/rrd_lastupdate.o .libs/rrd_first.o .libs/rrd_resize.o 
.libs/rrd_restore.o .libs/rrd_tune.o .libs/rrd_version.o .libs/rrd_xport.o 
.libs/art_rgba_svp.o .libs/rrd_gfx.o .libs/rrd_afm.o .libs/rrd_afm_data.o 
.libs/rrd_tool.o -Wl,--whole-archive ./.libs/librrdupd.a -Wl,--no-whole-archive 
/home/sshuser/rrdtool-1.2.23/lb/lib/libpng12.a -lz 
/home/sshuser/rrdtool-1.2.23/lb/lib/libart_lgpl_2.a -lm  -Wl,-soname 
-Wl,librrd.so.2 -o .libs/librrd.so.2.0.10
/usr/bin/ld: /home/sshuser/rrdtool-1.2.23/lb/lib/libfreetype.a(ftinit.o): 
relocation R_X86_64_32 against `tt_driver_class' can not be used when making a 
shared object; recompile with -fPIC
/home/sshuser/rrdtool-1.2.23/lb/lib/libfreetype.a: could not read symbols: Bad 
collect2: ld returned 1 exit status
make[2]: *** [librrd.la] Error 1
make[2]: Leaving directory `/home/ssh

I first tried with Freetype version 2.1.10 (the one in the guide) and after 
that I ried also with most recent version 2.3.4. Both fails similar way when 

I wish you can help me, because it is essential to get this installed. :)

Here is my uname -a
Linux rrdma 2.6.20-15-generic #2 SMP Sun Apr 15 06:17:24 UTC 2007 x86_64 

Distro is Ubuntu Server 7.04 64-bit


Teemu Illikainen

More information about the rrd-users mailing list