[rrd-users] MACOSX Leopard - Compile

Christos Vasilakis cvasilak at gmail.com
Sat Nov 17 13:04:54 CET 2007

Hi all,
i am trying to compile rrdtool-1.2.25 under Macosx Leopard. I have  
downloaded the dependencies libart freetype2 libpng. All were compiled  
and installed under /usr/local/include and /usr/local/lib directories.

When trying to compile rrd it complained about missing libraries.  
Can't find /usr/local/include.

I tried with configure --includedir=/usr/local/include --libdir=/usr/ 
local/lib but no luck.

Then i followed the instructions from http://oss.oetiker.ch/rrdtool/doc/rrdbuild.en.html 
  mainly setting environmental variables but when i set them and tried  
configure i get the following error message

Audit Compilation Environment
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

What i am doing wrong? How can i pass /usr/local/include and /usr/ 
local/lib to the configure script?

Thank you in advance


More information about the rrd-users mailing list