[rrd-users] does rrd aberrant behaviuor detection really work ?

sylvain at meduse.homelinux.net sylvain at meduse.homelinux.net
Wed Oct 3 01:09:17 CEST 2007

Hello ,

thanks a lot for your answers !

I can confirm 2 things :

* the discussed bug is fixed in the latest 1.3-beta1 released (and also in
the latest svn snapshot).
* what i'm doing i a mass update in one time (about 2 weeks of update,
with a 300 seconds step, by using "./script.pl | rrdtool -").

Some people (me, and others, i hope...) want their old rrd without abd
transformed in rrd with abd, without losing history.

I've written a quick perl script that parse the output of a "rrdtool info
foo.rrd" and produce a bar.rrd with the same structure + abd structure,
but with no data.

I've written a very dirty other perl script that parse the output of
"rrdtool dump foo.rrd" and fill in bar.rrd with the data (for now, in only
takes care of RRA having a pdp_per_row=1).

I still have a little bug when datas contain NaN, but it will be hopefully
solved tomorow, or at least this week.

I use rrdtool at work (cacti + some homemade scripts), and i have some
constraints : what i do shouldn't be 'intrusive'.
More precisely, rrd perl package is not installed, and i should not
install it (don't try to understand, i have renounced my self :-/ ). Thas
whyl i'm parsing xml, instead of using perl bindaries.

I can't install some libs (pango, cairo, ...), so i produced at home a
static binary of rrdtool. That's not that easy, since the
--enable-static-programs dont realy work for now, and compiling some parts
by hand (without the makefile and libtool) is required.

If you (or someone else ?) think my quick and dirty perl scripts could
help, tell me, and i'll translate my french comments inside.

(sorry for my poor english)



> in the 1.3er dev cycle quite a lot happened to rrd_update ... first
> the whole write logic was redone for better performance and mmap
> ability ...
> then evan refactored the whole update code and fixed the bug he
> mentioned ...
> so in the whole process it could well be that other things were
> fixed ...
> there was for example a bug in ABD triggered when running rrdtool
> update with multiple updates in a single call on linux (it worked
> fine on solaris) which was gone after the dma update to rrd_update.

More information about the rrd-users mailing list