[rrd-users] RRDs::tune zeroing values

William Cassis will at nextlevelinternet.com
Thu Apr 17 00:37:25 CEST 2008


I'm running MRTG on Fedora Core 8 with RRDTool and am having problems
with MRTG updating rrd files with correct values.

MRTG version 2.15.1 (package 2.15.1-6.fc8)
RRDTool says it's version 1.2.99907080300 when I run rrdtool --help, but
the package is 1.3-0.6.beta3.fc8.

When MRTG runs, it seems that the 'tune' step is zeroing out the most
recent values in the rrd files.  Commenting out the section of the MRTG
perl executable that calls the RRDs::tune command has temporarily fixed
things, but that's probably not a good long-term fix ;).

Here's a snippet from my mrtg config file:

### Interface 11 >> Descr: 'FastEthernet0/10' | Name: 'Fa0/10' | Ip: ''
| Eth: '00-03-e3-36-20-0a' ###

Target[FastEthernet0_10]: \FastEthernet0/10:mrtg at office-sw01:::::2
SetEnv[FastEthernet0_10]: MRTG_INT_IP=""
MaxBytes[FastEthernet0_10]: 12500000
Title[FastEthernet0_10]: Traffic Analysis for FastEthernet0/10 --
PageTop[FastEthernet0_10]: <h1>Traffic Analysis for FastEthernet0/10 --
               <div id="sysdetails">
                                       <td>FastEthernet0/10 Test </td>
                                       <td>Max Speed:</td>
                                       <td>100.0 Mbits/s</td>


When I run MRTG with --debug="log", I get output that looks like this:

Creating the rrd:
--log: RRDs::create(/usr/local/mrtg/office-sw01/fastethernet0_10.rrd -b
1208374325 -s 300 DS:ds0:COUNTER:600:0:12500000
DS:ds1:COUNTER:600:0:12500000 RRA:AVERAGE:0.5:1:800
RRA:AVERAGE:0.5:6:800 RRA:AVERAGE:0.5:24:800 RRA:AVERAGE:0.5:288:800
RRA:MAX:0.5:1:800 RRA:MAX:0.5:6:800 RRA:MAX:0.5:24:800
--log: RRDs::update(/usr/local/mrtg/office-sw01/fastethernet0_10.rrd,
--log:  got: ???/???

Updating the rrd with values:
--log: RRDs::tune(/usr/local/mrtg/office-sw01/fastethernet0_10.rrd -a
ds0:12500000 -a ds1:12500000 -d ds0:COUNTER -d ds1:COUNTER)
--log: RRDs::update(/usr/local/mrtg/office-sw01/fastethernet0_10.rrd,
--log:  got: ???/???

However, the rrd records 'NaN' values for that interval:
<!-- 2008-04-16 13:20:00 PDT / 1208377200 --> <row><v> NaN </v><v> NaN
<!-- 2008-04-16 13:25:00 PDT / 1208377500 --> <row><v> NaN </v><v> NaN
<!-- 2008-04-16 13:30:00 PDT / 1208377800 --> <row><v> NaN </v><v> NaN

After commenting out 'RRDs::tune(@args);' in the mrtg executable, the
rrds are updating with correct values.

I figured that this might be par for the course since I'm running a beta
version of rrdtool, but unfortunately yum doesn't give me an option to
install a stable version of rrdtool and I have quite a few other
packages that are dependencies on the version of rrdtool that the system
has installed.

Is this a known bug?

Any help is appreciated!

Will Cassis

More information about the rrd-users mailing list