[rrd-users] RRDTool on Blue Host

Chris chris at montfordhouse.com
Sat Apr 26 04:47:48 CEST 2008

I'm trying to install rrdtool on a shared server:

configure: WARNING:
* I could not find a working copy of libart-2.0. Check config.log for hints on why
  this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
  so that compiler and the linker can find libart_lgpl_2 and its header files. If
  you have not installed libart-2.0, you can get it either from its original home on


  You can find also find an archive copy on


  The last tested version of libart-2.0 is 2.3.17.

  CPPFLAGS= -I/usr/include/libart-2.0


I downloaded and installed the libart from oss.oetiker.ch/rrdtool/pub/libs.
using this .configure setup:
./configure --prefix=/home/myuser/local --with-libs=/home/myuser/local/lib --with-includes=/home/myuser/local/include
then make and make install.  libart seemed to install fine.

Assuming I can just assign the variables in bash before the configure command line,
I set them thus:
env CPPFLAGS="-I/home/myuser/local/include/libart-2.0" LIBS="-lm" LDFLAGS="-L/home/myuser/local/lib"
set BUILD_DIR=/home/myuser/tmp/rrdbuild
set INSTALL_DIR=/home/myuser/local

Then I tried the same configure command line from ~/rrdtool-1.2.27.
I still get the same problem. Also the LIBS, LDFLAGS and CPPFLAGS still show as above.

Any help will be greatly appreciated.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20080425/b5dc2b71/attachment.html 

More information about the rrd-users mailing list