[rrd-users] PHP Binding - php_rrdtool.tgz - Invalid Archive

Christos Vasilakis cvasilak at gmail.com
Fri Aug 15 11:08:22 CEST 2008

Bernard Li wrote:
 > Hi Christos:
 > On Sat, Aug 9, 2008 at 1:41 PM, Christos Vasilakis 
<cvasilak at gmail.com> wrote:
 >> I tried to download the php_rrdtool.tgz from the contrib directory
 >> http://oss.oetiker.ch/rrdtool/pub/contrib/) but unfortunately when I try
 >> to open it I get an error of invalid archive (under Linux)
 > # wget http://oss.oetiker.ch/rrdtool/pub/contrib/php_rrdtool.tgz
 > --14:18:57--  http://oss.oetiker.ch/rrdtool/pub/contrib/php_rrdtool.tgz
 >            => `php_rrdtool.tgz'
 > Resolving oss.oetiker.ch...
 > Connecting to oss.oetiker.ch||:80... connected.
 > HTTP request sent, awaiting response... 200 OK
 > Length: 9,353 (9.1K) [text/plain]
 > 9,353         41.76K/s
 > 14:18:58 (41.69 KB/s) - `php_rrdtool.tgz' saved [9353/9353]
 > # tar -zxvf php_rrdtool.tgz
 > rrdtool/
 > rrdtool/config.m4
 > rrdtool/php_rrdtool.h
 > rrdtool/rrdtool.c
 > rrdtool/rrdtool_logo.h
 > Unless Tobi has already fixed this :-)
 > Cheers,
 > Bernard

Hi Bernard,

I tried the same technique as yours using wget and works beautifully. 
Unfortunately though it fails miserably when you try to download it 
using a web browser(a more common thing to do I think). If you do 
through the browser, the tgz archive you download is invalid and can't 
be open. I tried the other tar.gz archives and they download and open 
fine. Only the php_rrdtool.tgz has the problem. I noticed though that 
when i click on the php_rrdtool.tgz the browser opens the contents 
inside the browser(garbage data) while with the other types of archive 
tar.gz when I click it offers me the option dialog to do a save as.

The browser I use is Mozilla Firefox v.3.0.1 under Ubuntu Hardy


More information about the rrd-users mailing list