[rrd-users] RRDs.pm/RRDs.so errors

David Brodin brodin at durd.net
Wed Jan 2 03:42:02 CET 2008

Well, im a bit ashamed of myself, ive fixed it.
What i didnt do was to try and run rrdtool by itself. When i did this i saw
an error that i recognized from earlier on from another program.

[root at MyBookWorld ~]# /usr/local/rrdtool-1.2.26/bin/rrdtool
/usr/local/rrdtool-1.2.26/bin/rrdtool: can't load library 'librrd.so.2'

RRDtools /lib/ was missing from ld.so.conf. Once added and 'ldconfig' was
run everything worked and im now running MRTG with RRDtool.

Thanks for the help tho, it did get me checking for solutions again :)


On Jan 2, 2008 2:05 AM, Dawn Keenan <dkeenan at mailservices.uwaterloo.ca>

> David Brodin wrote:
> > Hi all!
> >
> > Im new to the list, so be gentle :)
> >
> > Anyway, im hacking my MyBook World Edition and am trying to set up MRTG
> > with RRDtool. But i cant get around this error, ive tried everything i
> > can think of except emailing this list (until now obv):
> >
> > Can't load
> > '/usr/local/rrdtool-1.2.26
> /lib/perl/5.8.8/armv5tejl-linux//auto/RRDs/RRDs.so'
> > for module RRDs: File not found at
> > /usr/local/lib/perl5/5.8.8/armv5tejl-linux/DynaLoader.pm line 230.
> >  at /usr/local/mrtg-2/bin/mrtg line 342
> > Compilation failed in require at /usr/local/mrtg-2/bin/mrtg line 342.
> The error says that Perl can't find the shared object file 'RRDs.so' in
> the directory path given in the error message.  If you built RRDtool
> (likely given the rest of your message), there should be files named
> RRDs.so and RRDs.bs which were installed somewhere as a result of the
> build (with copies under your build directory).  Copying those files to
> /usr/local/rrdtool-1.2.26/lib/perl/5.8.8/armv5jeil-linux/auto/RRDs/
> should fix this problem.
> I'm assuming you are using the same version of Perl to build MRTG as you
> used for RRDtool.  If not, you will need to build both with the same Perl.
> Adding Pango and Cairo to the dependencies of RRDtool 1.3 has definitely
> increased the complexity of the build process.
> --
> Dawn Keenan
> Token Software Guy, Network Services, University of Waterloo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20080102/5c70a1cd/attachment.html 

More information about the rrd-users mailing list