[rrd-users] rrdtool graph confusion

Emily Chouinard cousin17 at msu.edu
Tue Jul 1 17:23:17 CEST 2008

I'm having 2 issues with the rrdtool graph command.

1st I can't seem to get the new line command to work, this is what I 
have in my code 'GPRINT:avgN:"Avg %6.2lf%%\n"', and when graphed the /n 
gives a character that look like a box ,[], and I don't know how to deal 
with this.

2nd I'm trying to comment the current date at the bottom of my graph but 
am so far unsuccessful. I've tried  COMMENT:"%m/%d/%Y %H\:%M\:%S",  and 
I tried declaring cur_date = '%m/%d/%Y %H\:%M\:%S' and then commenting 
cur_date COMMENT:"' + cur_date + '" and neither are working for me.  I 
get the following error:

 Traceback (most recent call last):
  File "cpu_usage.py", line 78, in ?
 ' COMMENT:"' + cur_date + '"')
rrdtool.error: Could not make sense out of ' COMMENT:"%m/%d/%Y %H\:%M\:%S"'

I'm probably missing something very basic (oh and I'm using python so 
thats why everything is being passed as a string)

Thanks for all your help so far, I've really appreciated it!!!

More information about the rrd-users mailing list