[rrd-users] random, but reproducible problem with updates

liege2477 liege2477 at yahoo.com
Mon Mar 10 22:23:46 CET 2008

Hey all,
 I am having a very odd problem that I just can't track down.  I'm fairly new to rrdtool, but have gone through all the n00b stuff that I can find.
 To start, I'm creating my databases like this:
 rrdtool create blah.rrd  --step 300 DS:cpu:GAUGE:600:0:100 DS:sess:GAUGE:600:0:1000000 DS:memfree:GAUGE:600:0:2048 DS:memused:GAUGE:600:0:2048 RRA:AVERAGE:0.5:1:52560 RRA:AVERAGE:0.5:12:4380 RRA:AVERAGE:0.5:288:183
 The files are all kept under a common data tree with the last two directories being like:
 The update looks like this:
  rrdtool update ./blah.rrd N:5:76:17:78
 The "SomeName" can contain spaces, dashes, underscores, etc and the numbers are the IP address of a particular device.  Sorry, I can't give a direct example here.  Inside of the final directory will be ONE of the above rrd files and MANY other rrd files with a different structure, one for each of the interfaces on that device.  This concept is repeated many times for each "SomeName", hundreds of times (for each device) with thousands of files (interfaces) (I'm speaking total here...not thousands per device).
 Now, my problem is that under some domains (the entire "SomeName" domain), the above referenced rrd file will not update for every device directory, but the OTHER rrd file for the interfaces updates fine from the same script.  Naming convention doesn't matter for the file or the directory (sometimes "SomeName" with a space works, sometimes it doesn't and vice versa...but generally more problematic for names with spaces).  The above filename is obviously bogus, but I've tried with a few different variations on structure...not to mention that more often than not my naming structure works fine.
 I am updating these files with a script every 5 minutes (PERL, but not using the RRDTool interface...I'm just using command line calls), which is not putting undo stress on the system nor is it spawning processes which are uncontrolled.  The "SomeName" directories that are having a problem are throughout the process  (so they aren't all at the beginning or end or grouped in any obvious way) and can be run independently with the same effect.  I have also tried running "rrdtool update" manually from the command line for a single file, both with a fully qualified path and a relative path from its own directory.  I don't get any errors unless I put in something that is obviously wrong (ie. too many or too few entries, incorrect timestamp, etc.).  So it LOOKS like everything is fine with the update.
 I have also tried destroying and re-creating the rrd files from scratch, to no effect.  If I fetch the data from the command line, I get a screen full of the default NaN values, so graphing gives me a blank graph.  I'm really at a loss and any help would be appreciated!
Looking for last minute shopping deals?  Find them fast with Yahoo! Search.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20080310/fc759e39/attachment-0001.html 

More information about the rrd-users mailing list