[rrd-users] mrtg + rrdcached

Steven Hartland killing at multiplay.co.uk
Tue Feb 2 00:59:59 CET 2010

I tried getting mrtg to work with rrdcached but it uses updatev
in the rrdtool v1.2+ code path so it doesn't work. Looking through
the code it seemed like there was no reason why if we forced the
old 1.1 path it wouldn't work just fine.

Thought it was worth a shot so tried it, and it works great!

In fact it works better than great, it transformed out stats 
machine from a totally unusable box, due to excessive io, back
to what it was before we started running mrtg on it :)

Given this I thought I'd share this experience, so others can

The patch attached is what we changed, its pretty rough with the
cache server hard coded but it would be easy to fix that and works ;-)

Hopefully future version of rrd will add updatev support to cached
so this isn't needed but in the mean time we're just really happy
to see the massive improvement that this new version brings, so
thanks to everyone who worked on it!


This e.mail is private and confidential between Multiplay (UK) Ltd. and the person or entity to whom it is addressed. In the event of misdirection, the recipient is prohibited from using, copying, printing or otherwise disseminating it or any information contained in it. 

In the event of misdirection, illegible or incomplete transmission please telephone +44 845 868 1337
or return the E.mail to postmaster at multiplay.co.uk.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mrtg.patch
Type: application/octet-stream
Size: 1557 bytes
Desc: not available
Url : http://lists.oetiker.ch/pipermail/rrd-users/attachments/20100201/66883d57/attachment.obj 

More information about the rrd-users mailing list