[rrd-users] RRDTools Server and Installing RRDTools in a shared hosting environment

AllSort ofQuestions allsortofquestions at yahoo.com
Sun Jan 10 02:48:46 CET 2010

OK I can say it is working under RH EL5.
What I did was to manually unpack the RPM and to copy the files in a subdirectory where I have full access
The next step was to use the perl directive "use lib" to point the perl script to that path. It worked with 

Next I tried higher versions because I need the "--no-border" and some other things which seem to be available 
only in later versions (haven't checked the linux version but the windows version I am using rejects the -no-border
I have tried -no-border on Ubuntu and it is not working in version 1.30.

Anyway, no matter what which version I try between 1.2.30 and 1.3.9 (RPMs) I am receiving the same message which is

Can't load
for module RRDs: librrd.so.2: cannot open shared object file: No such file or
directory at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line
 at script.pl line 3
Compilation failed in require at script.pl line 3.

Can anybody tell me what makes the 1.0.5 works and what makes all the other higher version fail?

I also tried to install the binaries, I am OK if I can create script that I can put in crontab and generate the images with rrdtool 1.3.9 while I am updating the database with 1.050. Would this work?
The binary distribution seems to have some problems with loading the libraries. Does anybody know how to load the libraries if the are not installer in /usr/lib or /usr/local/lib ?

I also tried /lib/ld-linux.so.2 --library-path PATH EXECUTABLE

This somehow change something but I don't know enough about Unix to say what exactly changed. Please see below

[user at p3nlh047 bin]$ ./rrdtool
./rrdtool: error while loading shared libraries: librrd.so.4: cannot open shared object file: No such file or directory


[user at p3nlh047 bin]$ /lib/ld-linux.so.2 --library-path . rrdtools
rrdtools: error while loading shared libraries: rrdtools: cannot open shared object file
[cristip at p3nlh047 bin]$

Thank you

From: Simon Hobson <linux at thehobsons.co.uk>
To: rrd-users at lists.oetiker.ch
Sent: Sat, January 9, 2010 12:27:37 PM
Subject: Re: [rrd-users] RRDTools Server and Installing RRDTools in a shared hosting environment

AllSort ofQuestions wrote:

>I have two questions somehow related to each other. I asking these 
>questions because apparently I can't run rrdtools in a shared hosted 
>envirionmnet. (Linux-REd Hat @Godaddy www.godaddy.com)
>From what I could see they have perl available for their clients but 
>only a limited set of modules, probably the most popular ones, are 
>installed and you can not install your own.

You are unlikely to be able to run any software not already 
supported. On a typical shared web hosting service, the server hosts 
multiple sites all using a common set of software. Whilst I believe 
it should be technically possible to install your own binaries in 
your own storage space, in practice I would expect most shared 
hosting providers to prohibit this (either in their ToS or by 
technical restrictions - typically the server would be configured to 
not execute binaries outside of certain system wide shared 
directories) and this would impact on their more expensive services 
they'd rather you buy if you want to do this.

In my limited experience, the larger the hosting company, the less 
likely they are to be able to accommodate you - with only smaller 
companies with manually (or semi manually) managed servers having the 

Have you tried asking GoDaddy if they have a server with RRD Tools 
installed that they could move your site to ?

Simon Hobson

Visit http://www.magpiesnestpublishing.co.uk/ for books by acclaimed
author Gladys Hobson. Novels - poetry - short stories - ideal as
Christmas stocking fillers. Some available as e-books.

rrd-users mailing list
rrd-users at lists.oetiker.ch

Looking for the perfect gift? Give the gift of Flickr! 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/rrd-users/attachments/20100109/1e38e226/attachment-0001.htm 

More information about the rrd-users mailing list