[rrd-users] Can't get a graph

Alex van den Bogaerdt alex at vandenbogaerdt.nl
Sun Oct 3 13:59:44 CEST 2010

>> On one PC I run rrdtool v1.2.9. I can graph my data the way I like it.
>> I want to migrate to a newer OS which has rrdtool v1.3.8. I dumped the
>> rrd on the old installation and I restored on the new installation on a
>> different PC. Then I ran the same command as the old installation to get
>> a graph, but I get an empty image, i.e. there is no data. Rulers, text,
>> etc. are OK. On the old installation I get a nice image.
>> What am I doing wrong ?

> Is there nobody that can help me ? I tried to make a graph with the
> following command, to make sure the start and end were not involved :
> rrdtool graph test.png --width 550 --height 150
> DEF:Power=pv_monitor.rrd:PAC:MAX LINE1:Power#FF0000: -u 3000 -v Watt -t
> hallo
> Same result : on the new installation no data in the graph, the old
> installation's graph is OK.
> I'm going to try to include the pictures, first the good one : test-ok.png

It is hard to tell, but it looks as if the data is actually there but scaled 
way down onto the x-axis. If you look at numbers instead of a graph it may 
be easier to see.

Try to isolate the problem.
Don't look at the graphs, try rrdtool fetch.
Don't use fancy ways of specifying time, try to keep it simple.
You used dump and restore. Good. What happens if you dump the data on the 
new installation and look at it?


More information about the rrd-users mailing list