[rrd-users] rrdcached lose updates

Tomáš Nechutný nechtom at gmail.com
Mon Feb 28 09:49:07 CET 2011


First of all I should note that I'm using rrdtool 1.4.99910112300 from SVN.

My problem:

I measure response time of various pages from two machines (same arch). I use 
rrdcached on both. Today I wanted to move one RRD to other machine to retain 
history and start measuring from there. This is from the `destination' machine 
after copy.

$ rrdtool last reqtime.rrd
$ rrdtool last reqtime.rrd --daemon

Then I updated reqtime.rrd with values from 1298880405 to cca 1298881060 via 
UPDATE commands inside BATCH. Then I could see those values via PENDING 
command. So I run FLUSH for reqtime.rrd. After few minutes (several `timeout' 
periods) I run:

$ rrdtool last reqtime.rrd
$ rrdtool last reqtime.rrd --daemon

No updates were written to reqtime.rrd since then and there are no pending 
values. Even output queue is empty.

Am I doing something wrong?

Thanks for help.

Tomas Nechutny.

More information about the rrd-users mailing list