[rrd-users] Ruby bindings and

Tobias Oetiker tobi at oetiker.ch
Wed Jul 27 00:20:34 CEST 2011

Hi Troex,

make sure to have a look at the latest stable snapshot, I think
there are some ruby bindiToday Troex Nevelin wrote:

> Hello,
> I'm using ruby bindings to xport data from Munin RRDs insidng
> fixes


e rails app.
> Everything works fine until I get first error during RRD.xport. For example
> rrd file is missing, or my DEF/CDEF are in wrong format - I get an Exception
> - everything is okay this behaviour is correct, but when I run RRD.xport
> again
> with correct options inside same rails app (without restarting it) I always
> get the same first Exception, so if my script reads 20 rrds and I got error
> on 5th than the last 15 RRD will return the same error as 5th. I can get rid
> of that Exception only if I restart my Rails app.
> How can I flush this error from RRD library without restarting?
> I've looked through bindings/ruby/main.c ... maybe `reset_rrd_state();`
> should be used in `rb_rrd_xport` method as well? (I'm not familiar with C)

Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
http://it.oetiker.ch tobi at oetiker.ch ++41 62 775 9902 / sb: -9900

More information about the rrd-users mailing list