[rrd-users] Graph size changed between 1.2.28 and 1.4.5

Tobias Oetiker tobi at oetiker.ch
Mon May 30 14:31:26 CEST 2011

Hi Victor,

the complete graphics subsystem has been switched around from 1.2
to 1.3 this caused a number of changes ... in any event, the width
and hights settings only define the size of the canvas and not the
chart as such ... there is now an option to make --width and
--height act as outside sizes ...


Today Victor Engmark wrote:

> Hi all,
> I've recently taken over distribution of an RRDtool package for a Linux From Scratch distribution. After an upgrade from 1.2.28 to 1.4.5 the graphs are now smaller; they've gone from 615x241 to 600x229 pixels. It looks like this is related to the rendering of the vertical "icon"/watermark on the right side of the graph. I managed to get the *width* of the text down to the previous value by adding `--font WATERMARK:6:/path/to/DejaVuSansMono.ttf`, but now it's *taller* than before, and there's no bottom margin between it and the graph. In the previous version, the text was 6px tall, and now it's 8px (even with the --font setting above). The bottom margin has gone from 15px to 0px, making it hug the right side of the graph. The title text is also 2px taller, although neither the font nor the settings changed. Any idea what could have caused this?
> I've tried to reduce the logo font size, but then the text width is too low, and I've tried `--graph-render-mode=mono` <http://oss.oetiker.ch/rrdtool-trac/wiki/RRDtool13#GraphingwithCairoPango>.
> Cheers,
> Victor

Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
http://it.oetiker.ch tobi at oetiker.ch ++41 62 775 9902 / sb: -9900

More information about the rrd-users mailing list