[rrd-users] No graph with --logarithmic option

Bernard Quatermass bernard at quatermass.co.uk
Mon Sep 5 00:14:33 CEST 2011

On 31 Aug 2011, at 00:32, Liehann Loots wrote:

> Hi,
> I'm having trouble generating a graph with a logarithmic y-axis.
> My graphing command looks like this (I've tried to make it as simple as possible). If I leave out the "-o" it works, with the "-o" - nothing.
> rrdtool graph pings.png \
>   -s end-2h -e now-1h \
>   -u 5000 -l 1 -o \
>   DEF:l=pings.rrd:latency:AVERAGE \
>   LINE2:l#00ff00
> Any help would be appreciated - I'm not even sure how to start debugging what's going wrong. It exits with code 0 and doesn't print out any error messages.
> I've tried two versions so far with the same result:
> rrdtool 1.4.3 (from Ubuntu 11.04 repo)
> rrdtool 1.4.5 (downloaded and compiled from source)
> Kind regards,
> Liehann
> _______________________________________________
> rrd-users mailing list
> rrd-users at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

This would be the same bug reported back in february in


with some analysis I did


The problem can be guaranteed to happen if you set


in rrd_graph_v()  before it calls rrd_graph_init. This way it should trigger a div-by-zero trap if not properly set.

I mentioned a hack I put in, patch attached, but my caveats stand as I'm not familiar with the codebase. But at least I have working log graphs.

Bernard Quatermass.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: rrdtool-1.4.4-magfact.patch
Type: application/octet-stream
Size: 518 bytes
Desc: not available
Url : http://lists.oetiker.ch/pipermail/rrd-users/attachments/20110904/5ab961e2/attachment.obj 
-------------- next part --------------

More information about the rrd-users mailing list