[rrd-users] rrdcached communication via socket.

Aramis aramis at pop-pr.rnp.br
Wed Jul 4 20:32:52 CEST 2012

Hi Stefan,

Thank you for helping.

 > how is u rrdcached running, what options ?

/usr/bin/rrdcached -P UPDATE,HELP,STATS,QUIT -l 
unix:/var/run/rrdcached.sock -w 420 -t 10 -s 33 -z 200 -j <long dir> -F 
-b <another long dir> -p /var/run/rrdcached.pid

 > I do use RRDs to connect to rrdcached via unix socket (not TCP) and
 > send RRDs::update.
 > See below:
 >    RRDs::update("$rrd", "--daemon", "$rrdcached_address", "$record");
 >    my $ERR=RRDs::error;
 >    rrd - is my rrd file on disk (For unix sockets Im really using
 >     abolsute paths to update)
 >    rrdcached_address - is my rrdcached socket address
 >     unix:/opt/sdr/report/var/cache/rrdcached/rrdcached.sock
 >    record - is the record I send to be updated
 > Works fine. Im testing this setup with over 100 rrds at the moment.

I tried to set $record as "N:$in:$out" and removed that "--template" 
stuff. No erros anymore. It worked!

But now only journal files are being written, and rrd files are not.

As far as I can tell, permissions are all correctly set.
Socket is writable by the user that runs RRD perl modules, the rrd files 
owner is ok. Only journal files belong to root.

I tried to flushall, but nothing happened.
Journals sizes keep growing up and when timeout (-w 420) comes, it 
shrinks and starts all over.

But rrd files stay untouched.

Any ideas?

More information about the rrd-users mailing list