[rrd-users] php rrdtool error

Benny Baumann BenBE at geshi.org
Wed Nov 14 18:07:38 CET 2012

For some weird reason you have to put '--start 1234567890' and '--step 3600' as the arguments.
Don't ask why. See the example in the mentioned archive.

Also not all early timestamps are accepted by librrd.


suja <sujaram at igcar.gov.in> schrieb:

>Thank you very much for the reply. I have tried the php binding given by
>you, but, unfortunately its giving the same error.
>I have tried the code with '--start' and '--step' arguments as well, but
>$opt=  array("--start",0,"--step",300, "DS:speed:COUNTER:600:U:U",
>     "RRA:AVERAGE:0.5:1:24",
>    "RRA:AVERAGE:0.5:6:10" );
>$ret = rrd_create($rrdFile,$opt, count($opt));
>is giving a 'Segmentation Fault".
>If I remove the '--' preceding start and step, the "cant Parse filename"
>error is repeating.
>View this message in context: http://rrd-mailinglists.937164.n2.nabble.com/php-rrdtool-error-tp7580605p7580614.html
>Sent from the RRDtool Users Mailinglist mailing list archive at Nabble.com.
>rrd-users mailing list
>rrd-users at lists.oetiker.ch

More information about the rrd-users mailing list