[rrd-users] Question about rrdcached

Steve Shipway s.shipway at auckland.ac.nz
Wed Sep 26 11:00:45 CEST 2012

This is odd, the -b should locate the files.

Can you confirm that none of the path of the RRD file is a soft link?  These break rrdcached (see the documentation) so if  /doado or /dado/rrd are softlinks it will not work.

Also verify the permissions on the path components match the userid the rrdcached is running as, if not using root.

Finally, this is a long shot, but try reorganising the parameters to rrdtool fetch:

rrdtool fetch MAX -s  $(date --date "Aug 01 00:00:00 2012" +%s) -e $(date --date "Aug 08 00:00:00 2012" +%s) --daemon

IE, put the --daemon last.  I seem to remember that there is something odd about the parser handling the parts separately and so this might be necessary.  Alternatively, try setting the environment var RRDCACHED_ADDRESS= before you run the rrdtool fetch.    Somehow, I am suspicious that it is not going via the daemon.


Steve Shipway
University of Auckland ITS
UNIX Systems Design Lead
s.shipway at auckland.ac.nz
Ph: +64 9 373 7599 ext 86487

From: Jairo Gubler [jairo.gubler at digitro.com.br]
Sent: Wednesday, 26 September 2012 8:02 a.m.
To: Steve Shipway
Cc: rrd-users at lists.oetiker.ch
Subject: Re: [rrd-users] Question about rrdcached

I tried, but this didn't solved the problem.

ps -ef |grep  rrdcached
root     10060     1  0 18:44 ?        00:00:00 rrdcached -w 600 -z 10
-j /dados/rrd/cached/ -p /dados/rrd/rrdcached.pid -b /dados/rrd -l

rrdtool fetch --daemon MAX -s  $(date --date "Aug
01 00:00:00 2012" +%s) -e $(date --date "Aug 08 00:00:00 2012" +%s)

ERROR: opening '': No such
file or directory

The file exists.
ls -l /dados/rrd/
-rw-r--r-- 1 root root 277216 Sep  2 13:46

Jairo Gubler

More information about the rrd-users mailing list