[rrd-users] RRD Graphs with bad averaging of missing data?

Alex van den Bogaerdt alex at vandenbogaerdt.nl
Tue Apr 8 15:52:02 CEST 2014

At a first glance this seems to be an artefact of normalization in 
combination with missing data.

Can you try a step size of 1 second, still updating every 5 seconds, 
heartbeat as desired?

----- Original Message ----- 
From: "Matt Elias" <eliaschief at gmail.com>
To: <rrd-users at lists.oetiker.ch>
Sent: Tuesday, April 08, 2014 3:23 PM
Subject: [rrd-users] RRD Graphs with bad averaging of missing data?

> Hi, I have an Ubuntu server (v12.10) running Perl (v5.14.2) scripts with
> the librrds-perl (v1.4.7-2) package. The Perl scripts connect to an
> Arduino and get temperature data from DS18B20 sensors. The shortest time
> frame I'm graphing is 1hr, so for a decent resolution, I'm updating the
> rrd database every 5 secs. Whenever a reading times out or the Arduino
> hangs, after the updates resume I see the anomalies shown on my image at
> 9:56-ish (see google driv link). I run other temperature rrd databases
> that have a step of 2mins and a heartbeat of 4mins that just show a gap
> when there's unknown data. For this rrd with a step of 5s, I've tried a
> heartbeat of 5s, 8s, 10s, 15s, 120s & 240s and they all have this issue.
> My Perl script also saves the Arduino data in a plain text file and when
> I compare it to the graph, the plain text file shows no erratic numbers
> that would cause the low spike, the data/time stamp just shows missing
> data. So I think it's either the graphing or the rrd database itself
> that is averaging an unknown value with a legit value and
> storing/displaying an incorrect value. Has anyone seem this behavior 
> before?
> https://drive.google.com/file/d/0B-KBMnHT5sWjdEltYlM0eG5rZ2c/edit?usp=sharing
> Matt
> _______________________________________________
> rrd-users mailing list
> rrd-users at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

More information about the rrd-users mailing list