[rrd-users] RRD was created on anther architecture - new install

Jon McGugan jon at mcgugan.co.uk
Sun Feb 14 16:02:52 CET 2016

Thanks for reply.

I am trying to use snm (http://snm.sourceforge.net/).

I have tried on Windows 7 but hit issues so decided to try in on Linux.

Fololwed snm installation details and to start with when the snm.pl was run it claimed RRDs 
was not installed. Overcame that by installing the rrdtool package (rather than compiling 
rrdtool) but then get the another architecture error from snm.

As far as I can work out there has to be a RRDs.pm in /use/lib/perl5 but the date time stamp 
on it does not match the rest of rrd and compiling rrdtool from source does not make one.
I think your second line is what is happening.
My usrlib/librrd is dated 2014 and is 4.2.0 but my RRDs.pm is dated 2012 (as I know very 
little about perl and rrd this may be a red herring).
I have tried removing all rrd stuff and starting again from source but I then fail to have a 
rdtool seems fine on it's own but at this time don't know how to use it on its own.

On 12 Feb 2016 at 22:13, Steve Shipway wrote:

> Can you be clear on how exactly you get the error?  How are you creating your RRD file?  How are you accessing it?  And so on.
> One possibility is that you are accessing via both the rrdtool binary, and the RRDs Perl library, and they have been compiled separately.  For example, you may have compiled your rrdtool binary using 64bit, but there is an existing librrd that is 32bit, and you do not realise you are still using it.
> If you create an RRD file using the rrdtool binary, then update/dump it using the same binary, I would expect it to work; similarly if you are using the same RRDs each time.
> Check your system's installed packages - do you have any RRDTool packages installed?  If so, remove them.  Check your library directories for other rrdtool installs and libraries from previous installs.  Remove all RRDs and associated files (check under the auto/RRDs path as well)
> Then run a new compile and install from source, when you are sure it is the only thing present, and make sure to compile 64bit if you can.
> When I have seen similar issues before, it has always been due to parts of old libraries hanging about when they shouldnt.
> Steve
> Steve Shipway University of Auckland ITS UNIX Systems Design Lead
> s.shipway at auckland.ac.nz Ph: +64 9 373 7599 ext 86487 
> ________________________________________
> From: rrd-users [rrd-users-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch] on behalf of Jon McGugan [jon at mcgugan.co.uk]
> Sent: Saturday, 13 February 2016 12:43 a.m.
> To: rrd-users at lists.oetiker.ch
> Subject: [rrd-users] RRD was created on anther architecture - new install
> I have searched the lists but all I can find is people trying to move to a new architecture. I am
> trying to install and run from scratch.
> Platform is Ubuntu 14.04 AMD
> The problem occurs when I try to run snm
> I have installed the rrdtool package and get the error
> I have downloaded the rrdtool source, compiled and installed and still the get the error.
> I suspect it is something to do with the RRDs.pm file which isn't rebuilt when I compile the
> source. But I am new to this so it is just a guess. without the RRDs.pm snm says RRDs isn't
> installed.
> Help appreciated.
> _______________________________________________
> rrd-users mailing list
> rrd-users at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/rrd-users

More information about the rrd-users mailing list