[rrd-users] Installing rrdtool on Linux machine

azeddine bezzir a_bezzir at yahoo.fr
Mon Feb 29 14:09:40 CET 2016

Yes i noticed that the post i shared is old, but have no choice, i couldn't find new ones.
Thank you for your time. i will try to do what do you suggested.
Best regards. 

    Le Lundi 29 février 2016 12h09, Simon Hobson <linux at thehobsons.co.uk> a écrit :

 I wrote:

> azeddine bezzir <a_bezzir at yahoo.fr> wrote:
>> In fact i downloaded the latest rrdtool package rrdtool-1.5.5, and tried to run the steps decribed in the below url:
>> http://www.cyberciti.biz/faq/howto-install-rrdtool-on-rhel-linux/
> Did you look at the date on that ? JULY 28, 2008 which is over 7 years old. You need to be aware that following random posts from many years ago is, in general, likely to give problems as things will have changed in that time.

Just to add, since that post tells you to install a load of packages with "yum install ..." then that too will fail without an internet connection.

Unless already installed, then you are going to have to manually install all the development tools required to build the RRD package (and possibly build all the dependencies as well). That's a "significant undertaking" to say the least - and the fact that you tried to follow that post suggests that you probably don't have the skills to do that.

Is there any way you can connect this system to the internet (temporarily) to install packages ?
The alternative is to download the rpm for rrdtool on a system that is internet connected, transfer it to the system in question, try to install that and see what dependencies are needed - the install will fail with a message to the effect that "package foo is needed but isn't installed". Download those, transfer them, and repeat until you either give up with an ever expanding list of missing dependencies - or succeed. You could start by downloading the list of packages yum install said it needed.

rrd-users mailing list
rrd-users at lists.oetiker.ch

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.oetiker.ch/pipermail/rrd-users/attachments/20160229/ef0435e7/attachment.html>

More information about the rrd-users mailing list