[rrd-users] unreadable strings from RRDTools charts

Alceu Rodrigues de Freitas Junior glasswalk3r at yahoo.com.br
Sun Apr 16 00:12:51 CEST 2017

Hello all,

I did a setup of Collectd in a VM with OpenBSD 6 installed to collect 
data and write to RRD files (RRDTool).

Everything seems to be running OK, but all my attempts of generating 
charts are resulting into something like this:


It's a bit hard to describe (there is a data curve at right, small 
because I'm running for a few minutes only), but it seems all strings 
that were supposed to be there were replaced by rectangles. I tried 
generating charts from all 3 Perl solutions available in the Collectd 
contrib tarball and also with rrdscout (Python based), all producing the 
same results.

If I would have to guess, I would say it is something with RRDTool libs 
and/or graphic related libs. I tried to follow up all requirements from 
RRDTool website, installed them over OpenBSD (even though the related 
package didn't required them), but results remain the same.

That is happening for all resources I'm monitoring (CPU, load and memory).

I can share the RRD files if necessary, this is for a free software 
project anyway (https://github.com/glasswalk3r/cpan-openbsd-smoker).

Please let me know if any of you already experimented this kind of problem.

Thanks in advance,


More information about the rrd-users mailing list